7-1 (базовый уровень, время – 3 мин)

Тема: Электронные таблицы.

Что нужно знать:

·    адрес ячейки в электронных таблицах состоит из имени столбца и следующего за ним номера строки, например, C15

·    формулы в электронных таблицах начинаются знаком = («равно»)

·    знаки +, –, *, / и ^ в формулах означают соответственно сложение, вычитание, умножение, деление и возведение в степень

·    запись B2:C4 означает диапазон, то есть, все ячейки внутри прямоугольника, ограниченного ячейками B2 и C4:

·    например, по формуле =СУММ(B2:C4) вычисляется сумма значений ячеек B2, B3, B4, C2, C3 и C4

·    в заданиях ЕГЭ могут использоваться стандартные функции СЧЕТ (количество непустых ячеек), СУММ (сумма), СРЗНАЧ (среднее значение), МИН (минимальное значение), МАКС (максимальное значение)

·    функция СРЗНАЧ при вычислении среднего арифметического не учитывает пустые ячейки и ячейки, заполненные текстом; например, после ввода формулы в C2 появится значение 2 (ячейка А2 – пустая):

функция СЧЕТ(A1:B2) в этом случае выдаст значение 3 (а не 4).

·    адреса ячеек (или ссылки на ячейки) бывают относительные, абсолютные и смешанные, вся разница между ними проявляется при копировании формулы в другую ячейку:

o   в абсолютных адресах перед именем столбца и перед номером строки ставится знак доллара $, такие адреса не изменяются при копировании; вот что будет, если формулу =$B$2+$C$3 скопировать из D5 во все соседние ячейки

знак $ как бы «фиксирует» значение: в абсолютных адресах и имя столбца, и номер строки зафиксированы

o    в относительных адресах знаков доллара нет, такие адреса при копировании изменяются: номер столбца (строки) изменяется на столько, на сколько отличается номер столбца (строки), где оказалась скопированная формула, от номера столбца (строки) исходной ячейки; вот что будет, если формулу =B2+C3 (в ней оба адреса – относительные) скопировать из D5 во все соседние ячейки:

o   в смешанных адресах часть адреса (строка или столбец) – абсолютная, она «зафиксирована» знаком $, а вторая часть – относительная; относительная часть изменится при копировании так же, как и для относительной ссылки:

Пример задания:

Р-10. Дан фрагмент электронной таблицы. Из ячейки D2 в одну из ячеек диапазона E1:E4 была скопирована формула. При копировании адреса ячеек в формуле автоматически изменились, и значение формулы стало равным 8. В какую ячейку была скопирована формула? В ответе укажите только одно число – номер строки, в которой расположена ячейка.

 

А

В

С

D

Е

1

1

2

3

4

 

2

2

3

4

=B$3+$C2

 

3

3

4

5

6

 

4

4

5

6

7

 

Решение:

1)      поскольку в формуле, которая записана в ячейку D2, две смешанных ссылки, в первой заблокирована строка 3, а во второй – столбец C

2)      формула перемещается в столбец E (на 1 столбец вправо), поэтому в первой ссылке адрес столбца будет C, так что формула примет вид:

=C$3 + $C?

где вместо знака вопроса будет некоторый номер строки – той строки, в которую скопируют формулу

3)      значение ячейки C3 равно 5, для того, чтобы получить в сумме 8, нужно добавить к нему число 3 – в столбце С оно находится в ячейке C1; поэтому формулу нужно скопировать в первую строку (в ячейку E1).

4)      ответ: 1.

Ещё пример задания:

Р-09. Коле нужно с помощью электронных таблиц построить таблицу квадратов двузначных чисел от 20 до 59. Для этого сначала в диапазоне В11 он записал числа от 0 до 9, и в диапазоне А2:А5 он записал числа от 2 до 5. Затем в ячейку В5 записал формулу квадрата двузначного числа (А5 – число десятков; В1 – число единиц), после чего скопировал её во все ячейки диапазона B2:К5. В итоге получил таблицу квадратов двузначных чисел. На рисунке ниже представлен фрагмент этой таблицы.

 

А

В

С

D

Е

1

 

0

1

2

3

2

2

400

441

484

529

3

3

900

961

1024

1089

4

4

1600

1681

1764

1849

5

5

2500

1601

2704

2809

Какая формула была записана в ячейку В5?

1) =(B1+10*А5)^2    2) =($B1+10*$А5)^2      3) =(B$1+10*$А5)^2      4) =($B1+10*А$5)^2

Решение:

5)      посмотрим, куда ссылаются правильные формулы в B5 и в какой-нибудь другой ячейке, которая отличается от B5 и строкой, и столбцом, например, в D3:

6)      смотрим, что в тих формулах меняется, а что не меняется; видим, что в первой ссылке не меняется строка 1, а во второй – столбец А, их и нужно сделать абсолютными, заблокировать с помощью знака $

7)      поэтому в B5 нужно ввести формулу =(B$1+10*$A5)^2

8)      Ответ: 3.

Решение (частный случай, А.Н. Носкин):

1)      проанализируем предлагаемые ответы на наличие «конфликта» при копировании в другие ячейки.

2)      в трёх вариантах ответа, а именно в 1, 2 и 4 есть ссылки B1 или $B1, в которых  не заблокирована первая строка; это значит, что при копировании такой формулы «вверх» номер строки станет нулевым или отрицательным, а нулевых или отрицательных строк (столбцов) в Excel не существует.

3)      поэтому в B5 нужно ввести формулу =(B$1+10*$A5)^2

4)      Ответ: 3.

Ещё пример задания:

Р-08. Нужно с помощью электронных таблиц построить таблицу значений формулы 2х+3у для значений х и у от 4 до 7. Для этого сначала в диапазонах В11 и А2:А5 записали числа от 4 до 7. Затем в ячейку В5 записали формулу (А5 - значение х, В1 – значение y), после чего эта формула была скопирована во все ячейки диапазона В2:Е5. В итоге на экране получился фрагмент таблицы.

 

А

В

С

D

Е

1

 

4

5

6

7

2

4

20

23

26

29

3

5

22

25

28

31

4

6

24

27

30

33

5

7

26

29

32

35

Какая формула была записана в ячейку В5?

1) =$А5*2+В$1*3     2) =А5*2+В1*3                3) =$А5*2+$В1*3            4) =А$5*2+$В1*3

Решение:

1)      посмотрим, куда ссылаются правильные формулы в B5 и в какой-нибудь другой ячейке, которая отличается от B5 и строкой, и столбцом, например, в D3:

2)      смотрим, что в тих формулах меняется, а что не меняется; видим, что в первой ссылке не меняется столбец А, а во второй – строка 1, их и нужно сделать абсолютными, заблокировать с помощью знака $

3)      поэтому в B5 нужно ввести формулу =$A5*2+B$1*3

4)      Ответ: 1.

Решение (частный случай, А.Н. Носкин):

1)      проанализируем предлагаемые формулы

1) =$А5*2$1*3     2) =А5*2+В1*3                3) =$А5*2+$В1*3            4) =А$5*2+$В1*3

2)      формулы 2, 3 и 4 содержат ссылки на B1, в которых номер строки 1 не закреплён абсолютной ссылкой, то есть будет изменяться при копировании

3)      поэтому при копировании формул 2, 3 и 4 из В5 вверх (в строку с меньшим номером) номер строки должен получиться меньше 1,   что приведет к ошибочной ссылке

4)      следовательно, варианты 2, 3 и 4 не подходят

5)      Ответ: 1.

Ещё пример задания:

Р-07. В ячейке E15 электронной таблицы записана формула. Эту формулу скопировали в ячейки D17 и C18. В соответствии с формулой, полученной в ячейке D17, значение в этой ячейке равно разности значений в ячейках D32 и C32; в соответствии с формулой, полученной в ячейке C18, значение в этой ячейке равно разности значений в ячейках D33 и B32. Укажите, какая формула могла быть написана в ячейке E15.

1) =E$32-D$30            2) =$D$32-$B$32             3) =$D$30-$C$32             4) =$D30-D$32

Решение:

1)      одну и ту же формулу скопировали в две ячейки и получили:

         в E15   ?

?  → в D17  → D32 – C32

?  → в C18  → D33 – B32

2)      видим, что обе целевые ячейки, D17 и C18, относятся к разным столбцам и разным строкам,  в то же время в обеих формулах в первой ссылке – столбец D, а во второй – строка 32

3)      следовательно, эти части ссылок абсолютные, они заблокированы от изменений знаком $

4)      номера строк в первой ссылке и имена столбцов во второй – разные, они относительные

5)      таким образом, получаем формулу =$D30 – D$32

6)      Ответ: 4.

Ещё пример задания:

Р-06. В ячейке X15 электронной таблицы записана формула. Эту формулу скопи­ровали в ячейку Z13. В соответствии с формулой, полученной в ячейке Z13, значение в этой ячейке равно произведению значений в ячейках D20 и E25. Напишите, сколько из следующих четырёх утверждений не противоречат этим данным.

1. Значение в ячейке X15 равно х*у, где х - значение в ячейке D20, а у - значение в ячейке C27.

2. Значение в ячейке X15 равно х*у, где х - значение в ячейке B20, а у - значение в ячейке E25.

3. Значение в ячейке X15 вычисляется по формуле х*у, где х - значение в ячейке D22, а у - значение в ячейке C25.

4. Значение в ячейке X15 равно х2, где х - значение в ячейке E27.

         1) 1                        2) 2                        3) 3                        4) 4

Решение:

7)      по условию мы знаем, что в ячейке Z13 записана формула =D20*E25, в которой каждая ссылка может быть абсолютной, относительной и смешанной, то есть возможны, например, такие варианты =$D$20*$E$25, =D$20*$E25 и т.д.

8)      для того, чтобы определить, какая формула была в X15, нужно скопировать формулу из Z13 в X15, поменяв соответствующим образом ссылки, тип которых мы не знаем

9)      начнём с варианта с относительными ссылками: при копировании формулы из Z13 в X15 номер столбца уменьшается на 2 (Z®X), а номер строки – увеличивается на 2 (13®15), поэтому формула с относительными ссылками изменится так:

Z13: =D20*E25                 ®           X15: =B22*C27

10)   кроме того, каждая часть ссылки может быть защищена от изменений знаком $; например, для первой ссылки получаем такие варианты преобразования

D20  ® B22,  $D20  ® $D22,  D$20  ® B$20,  $D$20  ® $D$20, 

то есть первая ссылка может превратиться в B20, B22, D20 и D22

11)   аналогично вторая ссылка (E25) при копировании может превратиться в C25, C27, E25 и E27

12)   при проверке утверждений 1, 2 и 3 выясняется, что все адреса ячеек допустимые, то есть входят в перечисленные в пп. 4 и 5, поэтому эти утверждения не противоречат исходным данным.

13)   в утверждении 4 обе ссылки должны стать равны E27, это возможно для второй ссылки, но не для первой (см. п. 4), поэтому это утверждение не может быть верным.

14)   Ответ: 3.

Ещё пример задания:

Р-05. Дан фрагмент электронной таблицы.

 

A

B

C

D

1

1

2

3

 

2

5

4

=$A$2+B$3

 

3

6

7

=A3+B3

 

Чему станет равным значение ячейки D1, если в неё скопировать формулу из ячейки С2?

Примечание: знак $ обозначает абсолютную адресацию.

1) 18                         2) 12                                  3) 14                            4) 17

Решение:

1)      при копировании формулы в другую ячейку все абсолютные ссылки на строки и столбцы (перед которыми стоит знак $) сохраняются, а все относительные – изменяются в соответствии со сдвигом формулы: если, например, формулу скопировали на 3 столбца вправо и на одну строку вверх, все «незаблокированные» адреса столбцов увеличиваются на 3, а все номера строк, перед которыми нет знака $, уменьшаются на 1

2)      формула в ячейке С3 (=$A$2+B$3) содержит одну абсолютную ссылку ($A$2), которая при копировании не меняется (и строка, и столбец заблокированы) и одну смешанную (B$3), в которой столбец B будет изменяться, а строка 3 – нет

3)      при копировании из C2 в D1 столбец увеличивается на 1, поэтому вместо B будет C, так что окончательный вид формулы в ячейке D1 после копирования – «=$A$2+C$3»

4)      вычисление этого выражения дает 5 + (6 + 7) = 18, это вариант 1

5)      Ответ: 1.

Ещё пример задания:

Р-04. В ячейке B4 электронной таблицы записана формула = $C3*2. Какой вид приобретет формула, после того как ячейку B4 скопируют в ячейку B6? Примечание: знак $ используется для обозначения абсолютной адресации.

1) =$C5*4              2) =$C5*2                        3) =$C3*4                  4) =$C3*2

Решение:

1)      ссылка $C3 – это смешанная ссылка, в которой «заблокирован» столбец C, а строка 3 – это относительный адрес;

2)      после того, как ячейку B4 скопировали в B6, номер строки увеличился на 2, поэтому и в ссылке $C3 номер строки (относительная часть) также увеличится на 2, ссылка превратится в $C5

3)      константы при копировании формул не меняются, поэтому получится =$C5*2

4)      таким образом, правильный ответ – 2.

Возможные ловушки и проблемы:

·    если ошибочно посчитать, что знак $ защищает от изменений всю ссылку, получим неверный ответ 4

Ещё пример задания:

Р-03. Три страны: Королевство Бельгия, Королевство Нидерланды и Великое Герцогство Люксембург образуют экономико-политический союз, который носит название Бенилюкс. Ниже приведен фрагмент электронной таблицы, характеризующий каждую из стран союза и союз в целом:

 

А

B

C

D

1

Страна

Население
(тыс. чел)

Площадь
 (кв. км)

Плотность населения (чел / квм)

2

Бельгия

10 415

30 528

341

3

Нидерланды

16 357

41 526

394

4

Люксембург

502

2 586

194

5

Бенилюкс в целом

27 274

74 640

 

Какое значение должно стоять в ячейке D5?

1) 365       2) 929                   3) 310                   4) 2,74

Решение:

1)      нужно не забыть, что плотность населения вычисляется как отношение населения к площади (не наоборот!);

2)      население не забываем перевести из тысяч человек в единицы: 27 274 000 чел

3)      поэтому для всего Бенилюкса получаем 27 274 000 / 74 640 ≈ 365

4)      таким образом, правильный ответ – 1.

Возможные ловушки и проблемы:

·    в такой простой задаче есть сильная ловушка: ответ 4 (2,74) получается при «обратном» делении, то есть 74 640 / 27 274 ≈ 2,74

Еще пример задания:

Р-02. В электронной таблице значение формулы =СУММ(B1:B2) равно 5. Чему равно значение ячейки B3, если значение формулы =СРЗНАЧ(B1:B3) равно 3?

1) 8                           2) 2                                     3) 3                               4) 4

Решение:

1)      функция СУММ(B1:B2) считает сумму значений ячеек B1 и B2, поэтому B1 + B2 = 5

2)      функция СРЗНАЧ(B1:B3) считает среднее арифметическое диапазона B1:B3

3)      строго говоря, такие задачи некорректны, потому что

а)      функция СРЗНАЧ учитывает только числовые данные (числа или формулы, при вычислении которых получается число), то есть возможны варианты:

СРЗНАЧ(B1:B3)=СУММ(B1:B3), если есть только одна числовая ячейка

СРЗНАЧ(B1:B3)=СУММ(B1:B3)/2, если есть две числовых ячейки

СРЗНАЧ(B1:B3)=СУММ(B1:B3)/3, если все три ячейки – числовые

б)      в условии не задано, сколько числовых ячеек в диапазоне B1:B3

4)      в такой ситуации логичнее всего считать, что все три ячейки содержат числовые данные (во всех известных автору задачах такого типа используется именно это допущение)

5)      итак, в диапазон B1:B3 входят три ячейки; предполагаем, что все они содержат числовые данные, тогда среднее арифметическое – это сумма их значений, деленная на 3; таким образом B1 + B2 + B3 = 3 · 3 = 9

6)      поскольку B1 + B2 = 5, сразу получаем B3 = 9 – 5 = 4

7)      таким образом, правильный ответ – 4.

Возможные ловушки и проблемы:

·    чтоб сбить угадывание, среди ответов приведены сумма исходных данных (8) и их разность (2) , это неверные ответы

Еще пример задания:

Р-01. Дан фрагмент электронной таблицы:

 

А

В

С

1

10

20

= A1+B$1

2

30

40

 

Чему станет равным значение ячейки С2, если в нее скопировать формулу из ячейки С1? Знак $ обозначает абсолютную адресацию.

 1) 40                        2) 50                            3)60                             4) 70

Решение:

1)      это задача на использование абсолютных и относительных адресов в электронных таблицах

2)      вспомним, что при копировании все относительные адреса меняются (согласно направлению перемещения формулы), а абсолютные – нет

3)      в формуле, которая находится в C1, используются два адреса: A1 и B$1

4)      адрес A1 – относительный, он может изменяться полностью (и строка, и столбец)

5)      адрес B$1 – смешанный, в нем номер строки «зафиксирован» знаком доллара, а имя столбца – нет, поэтому при копировании может измениться только имя столбца

6)      при копировании из C1 в C2 столбец не изменяется, а номер строки увеличивается на 1, поэтому в C2 получим формулу =A2+B$1 (здесь учтено, что у второго адреса номер строки «зафиксирован»)

7)      сумма ячеек A2 и B1 равна 30 + 20 = 50

8)      таким образом, правильный ответ – 2.

Возможные ловушки и проблемы:

·    расчет на то, что ученик забудет, что абсолютная ссылка не меняется (тогда получится формула =A2+B$2, на этот случай дан неверный ответ 70)

 

Еще пример задания:

Р-00. Дан фрагмент электронной таблицы:

 

А

В

С

1

1

2

 

2

2

6

=СЧЁТ(A1:B2)

3

 

 

=СРЗНАЧ(A1:C2)

Как изменится значение ячейки С3, если после ввода формул переместить содержимое ячейки В2 в В3? («+1» означает увеличение на 1, а «–1» – уменьшение на 1)

 1) –2                       2) –1                            3) 0                              4) +1

Решение:

1)      это задача на знание особенностей функций СЧЕТ и СРЗНАЧ, которые не учитывают пустые ячейки

2)      после ввода формул в С2 окажется количество непустых ячеек диапазона А1:В2, равное 4

3)      в С3 будет выведено среднее значение диапазона А12 равное

 (1+2+2+6+4)/5 = 3

4)      после перемещения (не копирования!) содержимого ячейки В2 в В3 ячейка В2 окажется пустой, поэтому в С2 выводится число 3 – количество непустых ячеек диапазона А1:В2

5)      в С3 будет выведено среднее значение диапазона А12 равное

 (1+2+2+3)/4 = 2,

то есть значение С3 уменьшится на 1

6)      таким образом, правильный ответ – 2.

Возможные ловушки и проблемы:

·    нужно помнить, что при перемещении содержимого ячейки в другое место она становится пустой

·    нужно помнить, что функции СЧЕТ и СРЗНАЧ не учитывают пустые ячейки

 


Задачи для тренировки[1]:

1)      В ячейке B1 записана формула =2*$A1. Какой вид приобретет формула, после того как ячейку B1 скопируют в ячейку C2?

1) =2*$B1           2) =2*$A2               3) =3*$A2               4) =3*$B2Н

2)      В ячейке C2 записана формула =$E$3+D2. Какой вид приобретет формула, после того как ячейку C2 скопируют в ячейку B1?

1) =$E$3+C1     2) =$D$3+D2         3) =$E$3+E3         4) =$F$4+D2

3)      Дан фрагмент электронной таблицы:

 

A

B

C

D

1

5

2

4

 

2

10

1

6

 

В ячейку D2 введена формула 2*В1+С1. В результате в ячейке D2 появится значение:

1) 6                           2) 14                            3) 16                            4) 24

4)      В ячейке А1 электронной таблицы записана формула =D1-$D2. Какой вид приобретет формула после того, как ячейку А1 скопируют в ячейку В1?

1) =E1-$E2        2) =E1-$D2            3) =E2-$D2            4) =D1-$E2

5)      Дан фрагмент электронной таблицы:

 

А

В

С

D

1

1

2

3

 

2

4

5

6

 

3

7

8

9

 

В ячейку D1 введена формула =$А$1*В1+С2, а затем скопирована в ячейку D2. Какое значение в результате появится в ячейке D2?

1) 10                         2) 14                            3) 16                            4) 24

6)      В ячейке В2 записана формула =$D$2+Е2. Какой вид будет иметь формула, если ячейку В2 скопировать в ячейку А1?

1) =$D$2+E1 2) =$D$2+C2 3) =$D$2+D2 4) =$D$2+D1

7)      В ячейке СЗ электронной таблицы записана формуле =$А$1+В1. Какой вид будет иметь формула, если ячейку СЗ скопировать в ячейку ВЗ?

1) =$A$1+А1 2) =$В$1+ВЗ             3) =$А$1+ВЗ         4) =$B$1+C1

8)      При работе с электронной таблицей в ячейке ЕЗ записана формула 2+$СЗ. Какой вид приобретет формула после того, как ячейку ЕЗ скопируют в ячейку D2?

1) 1+$СЗ 2) =А1+$С2 3) =E2+$D2                              4) =D2+$E2

9)      В ячейке электронной таблицы В4 записана формула =С2+$A$2. Какой вид приобретет формула, если ячейку В4 скопировать в ячейку С5?

1) =D2+$В$3     2) =С5+$A$2         3) =D3+$A$2         4) =СЗ+$А$3

10)   В ячейке электронной таблицы А1 записана формула =$D1+D$2. Какой вид приобретет формула, если ячейку А1 скопировать в ячейку ВЗ?

1) =D1+$E2        2) =D3+$F2            3) =E2+D$2            4) =$D3$2

11)   Дан фрагмент электронной таблицы:

 

А

В

С

1

2

3

 

2

4

5

=СЧЁТ(A1:B2)

3

 

 

=СРЗНАЧ(A1:C2)

Как изменится значение ячейки С3, если после ввода формул переместить содержимое ячейки В2 в В3? («+1» означает увеличение на 1, а «–1» – уменьшение на 1):

1) –1                        2) –0,6                        3) 0                              4) +0,6

12)   В электронной таблице значение формулы =СРЗНАЧ(A6:C6) равно (-2). Чему равно значение формулы =СУММ(A6:D6), если значение ячейки D6 равно 5?

1) 1                          2) -1                           3) -3                             4) 7

13)   В электронной таблице значение формулы =СРЗНАЧ(A6:C6) равно 0,1. Чему равно значение формулы =СУММ(A6:D6), если значение ячейки D6 равно (–1)?

1) – 0,7                    2) -0,4                        3) 0,9                           4) 1,1

14)   В электронной таблице значение формулы =СРЗНАЧ(B5:E5) равно 100. Чему равно значение формулы =СУММ(B5:F5), если значение ячейки F5 равно 10?

1) 90                         2) 110                          3) 310                          4) 410

15)   В электронной таблице значение формулы =СРЗНАЧ(A6:C6) равно 2. Чему равно значение формулы =СУММ(A6:D6), если значение ячейки D6 равно -5?

1) 1                          2) -1                           3) -3                             4) 7

16)   В электронной таблице значение формулы =СУММ(C3:E3) равно 15. Чему равно значение формулы =СРЗНАЧ(C3:F3), если значение ячейки F3 равно 5?

1) 20                       2) 10                           3) 5                              4) 4

17)   В динамической (электронной) таблице приведены значения пробега автомашин (в км) и общего расхода дизельного топлива (в литрах) в четырех автохозяйствах с 12 по 15 июля.

 

12 июля

13 июля

14 июля

15 июля

За четыре дня

Название автохозяйства

Пробег

Расход

Пробег

Расход

Пробег

Расход

Пробег

Расход

Пробег

Расход

Автоколонна №11

9989

2134

9789

2056

9234

2198

9878

2031

38890

8419

Грузовое такси

490

101

987

215

487

112

978

203

2942

631

Автобаза №6

1076

147

2111

297

4021

587

1032

143

8240

1174

Трансавтопарк

998

151

2054

299

3989

601

1023

149

8064

1200

В каком из хозяйств средний расход топлива на 100 км пути за эти четыре дня наименьший?

1) Автоколонна № 11

2) Грузовое такси

3) Автобаза №6

4) Трансавтопарк

 

18)   В электронной таблице значение формулы =СРЗНАЧ(A1:C1) равно 5. Чему равно значение ячейки D1, если значение формулы =СУММ(A1:D1)равно 7?

1) 2                          2) -8                             3) 8                              4) -3

19)   В электронной таблице значение формулы =СРЗНАЧ(B1:D1) равно 4. Чему равно значение ячейки A1, если значение формулы =СУММ(A1:D1)равно 9?

1) -3                         2) 5                               3) 1                              4) 3

20)   В электронной таблице значение формулы =СРЗНАЧ(A1:B4) равно 3. Чему равно значение ячейки A4, если значение формулы =СУММ(A1:B3)равно 30, а значение ячейки B4 равно 5?

1) -11                       2) 11                            3) 4                              4) -9

21)   На рисунке приведен фрагмент электронной таблицы. Определите, чему будет равно значение, вычисленное по следующей формуле =СУММ(B1:C4)+F2*E4–A3

 

A

B

C

D

E

F

1

1

3

4

8

2

0

2

4

–5

–2

1

5

5

3

5

5

5

5

5

5

4

2

3

1

4

4

2

1) 19                         2) 29                            3) 31                            4) 71

22)   На рисунке приведен фрагмент электронной таблицы. Определите, чему будет равно значение, вычисленное по следующей формуле =СУММ(A1:C2)*F4*E2-D3

 

A

B

C

D

E

F

1

1

3

4

8

2

0

2

4

–5

–2

1

5

5

3

5

5

5

5

5

5

4

2

3

1

4

4

2

1) 15                      2) 0                               3) 45                            4) 55

23)   В электронной таблице значение формулы =СРЗНАЧ(A4:C4) равно 5. Чему равно значение формулы =СУММ(A4:D4), если значение ячейки D4 равно 6?

1) 1                          2) 11                            3) 16                            4) 21

24)   В электронной таблице значение формулы =СРЗНАЧ(A3:D4) равно 5. Чему равно значение формулы =СРЗНАЧ(A3:C4), если значение формулы =СУММ(D3:D4)равно 4?

1) 1                          2) 3                               3) 4                              4) 6

25)   В электронной таблице значение формулы =СРЗНАЧ(C2:D5) равно 3. Чему равно значение формулы =СУММ(C5:D5), если значение формулы =СРЗНАЧ(C2:D4)равно 5?

1) –6                        2) –4                            3) 2                              4) 4

26)   В динамической (электронной) таблице приведены значения посевных площадей (в га) и урожай (в центнерах).

Зерновые культуры

Заря

Первомайское

Победа

Рассвет

Посевы

Урожай

Посевы

Урожай

Посевы

Урожай

Посевы

Урожай

Пшеница

600

15600

900

23400

300

7500

1200

31200

Рожь

100

2200

500

11000

50

1100

250

5500

Овёс

100

2400

400

9600

50

1200

200

4800

Ячмень

200

6000

200

6000

100

3100

350

10500

Всего

1000

26200

2000

50000

500

12900

2000

52000

В каком из хозяйств достигнута максимальная урожайность зерновых (по валовому сбору, в центнерах с гектара)?

1) Заря                 2) Первомайское           3) Победа          4) Рассвет

 

27)   Дан фрагмент электронной таблицы:

 

B

C

D

69

5

10

 

70

6

9

=СЧЁТ(B69:C70)

71

 

 

=СРЗНАЧ(B69:D70)

После перемещения содержимого ячейки C70 в ячейку C71 значение в ячейке D71 изменится по абсолютной величине на:

1) 2,2                       2) 2,0                           3) 1,05                        4) 0,8

28)   Дан фрагмент электронной таблицы:

 

B

C

D

69

5

10

 

70

6

9

=СЧЁТ(B69:C70)

71

 

 

=СРЗНАЧ(B69:D70)

После перемещения содержимого ячейки B69 в ячейку D69 значение в ячейке D71 изменится по сравнению с предыдущим значением на:

1) –0,2                     2) 0                               3) 1,03                        4) –1,3

29)   В динамической (электронной) таблице приведены данные о продаже путевок турфирмой «Все на отдых» за 4 месяца. Для каждого месяца вычислено общее количество проданных путевок и средняя цена одной путевки.

Страна

май

июнь

июль

август

Продано, шт.

Цена, тыс. руб.

Продано, шт.

Цена, тыс. руб.

Продано, шт.

Цена, тыс. руб.

Продано, шт.

Цена, тыс. руб.

Египет

12

24

15

25

10

22

10

25

Турция

13

27

16

27

12

26

11

28

ОАЭ

12

19

12

22

10

21

9

22

Хорватия

5

30

7

34

13

35

10

33

Продано, шт.

42

 

50

 

45

 

40

 

Средняя цена, тысуб.

 

25

 

27

 

26

 

27

Известно, что доход фирмы от продажи каждой путевки не зависит от места отдыха и равен 10% от средней цены путевки в текущем месяце. В каком месяце доход турфирмы был максимальный?

1) май

2) июнь

3) июль

4) август

30)   В электронной таблице значение формулы =СРЗНАЧ(D1:D4) равно 8. Чему равно значение формулы =СРЗНАЧ(D2:D4), если значение ячейки D1 равно 11?

1) 19                         2) 21                            3) 7                              4) 32

31)   На рисунке приведен фрагмент электронной таблицы. В ячейку B2 записали формулу =($A2*10+B$1)^2 и скопировали ее вниз на 2 строчки, в ячейки B3 и B4. Какое число появится в ячейке B4?

 

A

B

C

D

1

 

0

1

1

2

1

 

 

3

2

 

 

 

4

3

 

 

 

5

 

 

 

 

1) 144                      2) 300                          3) 900                          4) 90

32)   На рисунке приведен фрагмент электронной таблицы. Чему будет равно значение ячейки B4, в которую записали формулу =СУММ(A1:B2;C3)?

 

A

B

C

D

1

1

2

3

 

2

4

5

6

 

3

7

8

8

 

4

 

 

 

 

1) 14                         2) 15                            3) 17                            4) 20

33)   В ячейке электронной таблицы С3 записана формула =B2+$D$3-E$2. Какой вид приобретет формула, если ячейку C3 скопировать в ячейку С4?

1) =B3+$G$3-E$2                               2) =B3+$D$3-E$3    
3)
=B3+$D$3-E$2                               4) =B3+$D$3-F$2

34)   На рисунке приведен фрагмент электронной таблицы. Какое число появится в ячейке C4, если скопировать в нее формулу из ячейки D3?

 

A

B

C

D

1

5

10

 

 

2

6

12

 

 

3

7

14

 

=B2+$B3-$A$1

4

8

16

 

 

1) 8                           2) 18                            3) 21                            4) 26

35)   На рисунке приведен фрагмент электронной таблицы. Какое число появится в ячейке D1, если скопировать в нее формулу из ячейки C2?

 

A

B

C

D

1

1

2

3

 

2

5

4

=$A2+$B$3

 

3

6

7

=A3+B3

 

1) 9                           2) 8                               3) 6                              4) 5

36)   На рисунке приведен фрагмент электронной таблицы. Какое число появится в ячейке D1, если скопировать в нее формулу из ячейки C2?

 

A

B

C

D

1

1

2

3

 

2

5

4

=A$2+$B$3

 

3

6

7

=A3+B3

 

1) 11                         2) 9                               3) 8                              4) 6

37)   На рисунке приведен фрагмент электронной таблицы. Какое число появится в ячейке D1, если скопировать в нее формулу из ячейки C2?

 

A

B

C

D

1

1

2

3

 

2

5

4

=$A$2+$B$3

 

3

6

7

=A3+B3

 

1) 12                         2) 16                            3) 13                            4) 14

38)   В ячейки диапазона C3:F6 электронной таблицы записаны числа, как показано на рисунке.

 

A

B

C

D

E

F

1

 

 

 

 

 

 

2

 

 

 

 

 

 

3

 

 

1

2

3

4

4

 

 

11

13

15

17

5

 

 

21

24

27

30

6

 

 

31

35

39

43

 

В ячейке A1 записали формулу =E$5-$D4. После этого ячейку A1 скопировали в ячейку B2. Какое число будет показано в ячейке B2? Примечание: знак $ используется для обозначения абсолютной адресации.

1) 6                           2) 14                            3) 16                            4) 24

39)   В ячейки диапазона C3:F6 электронной таблицы записаны числа, как показано на рисунке.

 

A

B

C

D

E

F

1

 

 

 

 

 

 

2

 

 

 

 

 

 

3

 

 

1

2

3

4

4

 

 

11

13

15

17

5

 

 

21

24

27

32

6

 

 

31

35

39

43

 

В ячейке A1 записали формулу =$D4+E$5. После этого ячейку A1 скопировали в ячейку B2. Какое число будет показано в ячейке B2? Примечание: знак $ используется для обозначения абсолютной адресации.

1) 40                         2) 54                            3) 56                            4) 70

40)   В ячейки диапазона C3:F6 электронной таблицы записаны числа, как показано на рисунке.

 

A

B

C

D

E

F

1

 

 

 

 

 

 

2

 

 

 

 

 

 

3

 

 

1

2

3

4

4

 

 

11

13

15

17

5

 

 

21

24

27

30

6

 

 

31

35

39

43

 

В ячейке В2 записали формулу =E$5-$D4. После этого ячейку В2 скопировали в ячейку А1. Какое число будет показано в ячейке А1? Примечание: знак $ используется для обозначения абсолютной адресации.

1) 22                         2) 14                            3) 12                            4) 4

41)   В ячейки диапазона C3:F6 электронной таблицы записаны числа, как показано на рисунке.

 

A

B

C

D

E

F

1

 

 

 

 

 

 

2

 

 

 

 

 

 

3

 

 

1

2

3

4

4

 

 

11

22

33

44

5

 

 

22

11

44

33

6

 

 

31

35

39

43

 

В ячейке В2 записали формулу =E$5+$D4. После этого ячейку В2 скопировали в ячейку А1. Какое число будет показано в ячейке А1? Примечание: знак $ используется для обозначения абсолютной адресации.

1) 66                         2) 44                            3) 23                            4) 13

42)   В ячейке D5 электронной таблицы записана формула. Эту формулу скопировали в ячейку С4. В результате значение в ячейке С4 вычисляется по формуле Зх+у, где х — значение в ячейке С22, а у — значение в ячейке D22. Укажите, какая формула могла быть написана в ячейке D5.

1) =3*C22+D22    2) =3*$C22+$D22   3) =3*C$22+D$22   4) =3*D$22+$D23

43)   В ячейке В11 электронной таблицы записана формула. Эту формулу скопировали в ячейку А10. В результате значение в ячейке А10 вычисляется по формуле х—Зу, где х — значение в ячейке С22, а у — значение в ячейке D22. Укажите, какая формула могла быть написана в ячейке В11.

1) =C22-3*D22            2) =D$22-3*$D23    3) =C$22-3*D$22    4) =$C22-3*$D22

44)   (http://ege.yandex.ru) В ячейке G4 электронной таблицы записана формула. Эту формулу скопировали в ячейку F3. В результате значение в ячейке F3 вычисляется по формуле 2xy, где x – значение в ячейке C22, а y – значение в ячейке D22. Укажите, какая формула могла быть написана в ячейке G4.

1) =2C22D22     2) =2$C22$D22    3)=2C$22D$22    4) =2D$22$D23

45)   В ячейке F10 электронной таблицы записана формула. Эту формулу скопировали в ячейку Е11. В соответствии с формулой, полученной в ячейке Е11, значение в этой ячейке равно сумме значений в ячейках В16 и А17. Напишите, сколько из следующих четырёх утверждений не противоречат этим данным.

1.   Значение в ячейке F10 равно х+у, где х - значение в ячейке В16, а у - значение в ячейке А17.

2.   Значение в ячейке F10 равно х+у, где х - значение в ячейке С15, а у - значение в ячейке А17.

3.   Значение в ячейке F10 вычисляется по формуле х+у, где х - значение в ячейке С16, а у - значение в ячейке А16.

4.   Значение в ячейке F10 равно 2*х, где х - значение в ячейке В16.

      1) 1                  2) 2                        3) 3                        4) 4

46)   В ячейке М21 электронной таблицы записана формула. Эту формулу скопи­ровали в ячейку L22. В соответствии с формулой, полученной в ячейке L22, значение в этой ячейке равно произведению значений в ячейках В36 и А37. Напишите, сколько из следующих четырёх утверждений не противоречат этим данным.

1. Значение в ячейке М21 равно х*у, где х - значение в ячейке В36, а у - значение в ячейке A37.

2. Значение в ячейке М21 равно х*у, где х - значение в ячейке С35, а у - значение в ячейке А37.

3. Значение в ячейке М21 вычисляется по формуле х*у, где х - значение в ячейке С36, а у - значение в ячейке А36.

4. Значение в ячейке М21 равно х2, где х - значение в ячейке В36.

                1) 1                        2) 2                        3) 3                        4) 4

47)   В ячейке F15 электронной таблицы записана формула. Эту формулу скопировали в ячейку E14. В результате значение в ячейке E14 вычисляется по формуле x+2*y, где x – значение в ячейке C42, а y – значение в ячейке D42. Укажите, какая формула НЕ могла быть написана в ячейке F15.

1) =$C$42+2*$D$42       2) =$C43+2*E$42             3) =$С43 + 2*$D43          4) =D$42+2*D43

48)   В ячейке D5 электронной таблицы записана формула. Эту формулу скопировали в ячейку C4. В результате значение в ячейке C4 вычисляется по формуле 3x+y, где x – значение в ячейке C22, а – значение в ячейке D22. Укажите, какая формула НЕ могла быть написана в ячейке D5.

1) =3*С22 + D22               2) =3*$C$22+$D$22       3) =3*D$22+$D23            4) =3*$C23+E$22

49)   (http://ege.yandex.ru) В ячейке D6 электронной таблицы записана формула. Эту формулу скопировали в ячейки C7 и B8. В соответствии с формулой, полученной в ячейке C7, значение в этой ячейке равно сумме значений в ячейках D21 и C22; в соответствии с формулой, полученной в ячейке B8, значение в этой ячейке равно сумме значений в ячейках D22 и B22. Укажите, какая формула могла быть написана в ячейке D6.

1) =$D20+D$22                 2) =$D$22+$B$22            3) =$D$21+$C$22            4) =E$22+$D20

50)   В ячейке E16 электронной таблицы записана формула. Эту формулу скопировали в ячейки D17 и C18. В соответствии с формулой, полученной в ячейке D17, значение в этой ячейке равно сумме значений в ячейках D32 и C31; в соответствии с формулой, полученной в ячейке C18, значение в этой ячейке равно сумме значений в ячейках D32 и B32. Укажите, какая формула могла быть написана в ячейке E16.

1) =$D30+D$30                 2) =$D$32+D30                 3) =$D$32+$D30              4) =D$32+$D30

51)   Нужно с помощью электронных таблиц построить таблицу значений формулы х+x*у для значений х и у от 5 до 8. Для этого сначала в диапазонах В11 и А2:А5 записали числа от 5 до 8. Затем в ячейку E3 записали формулу (А3 - значение х, E1 – значение y), после чего эта формула была скопирована во все ячейки диапазона В2:Е5. В итоге на экране получился фрагмент таблицы.

 

А

В

С

D

Е

1

 

5

6

7

8

2

5

30

35

40

45

3

6

36

42

48

54

4

7

42

49

56

63

5

8

48

56

64

72

Какая формула была записана в ячейку E3?

1) =A$3+A$3*$E1            2) =$A3+$A3*$E1                           3) =$A3+A$3*E$1            4) =$A3+$A3*E$1

52)   Коле нужно с помощью электронных таблиц построить таблицу двузначных чисел от 10 до 49. Для этого сначала в диапазоне В11 он записал числа от 0 до 9, и в диапазоне А2:А5 он записал числа от 1 до 4. Затем в ячейку В2 записал формулу двузначного числа (А2 – число десятков; В1 – число единиц), после чего скопировал её во все ячейки диапазона B2:К5. В итоге получил таблицу двузначных чисел. На рисунке ниже представлен фрагмент этой таблицы.

 

А

В

С

D

Е

1

 

0

1

2

3

2

1

10

11

12

13

3

2

20

21

22

23

4

3

30

31

32

33

5

4

40

41

42

43

Какая формула была записана в ячейку B2?

1) =$A2*10+$B1              2) =A$2*10+$B1              3) =$A2*10+B$1              4) =A2*10+B1

53)   В ячейке D5 электронной таблицы записана формула. Эту формулу скопировали в ячейку E4. В результате значение в ячейке E4 вычисляется по формуле 3x+y, где x – значение в ячейке G7, а – значение в ячейке H10. Укажите, какая формула НЕ могла быть написана в ячейке D5.

1) =3*F8 + G11                 2) =3*G7+H10   3) =3*$G$7+$H$10         4) =3*$G8+G$10

54)   В ячейки диапазона C2:F6 электронной таблицы записаны числа, как показано на рисунке.

 

А

В

С

D

Е

F

1

 

 

 

 

 

 

2

 

 

1

10

100

1000

3

 

 

2

20

200

2000

4

 

 

3

30

300

3000

5

 

 

4

40

400

4000

5

 

 

5

50

500

5000

В ячейке C1 записали формулу =E$2 + $F3. После этого ячейку C1 скопировали в ячейку A3. Какое число будет показано в ячейке A3?

Примечание: знак $ используется для обозначения абсолютной адресации.

1) 43                      2) 320                   3) 2100                 4) 4001

55)   В ячейки диапазона C2:F6 электронной таблицы записаны числа, как показано на рисунке.

 

А

В

С

D

Е

F

1

 

 

 

 

 

 

2

 

 

1

10

100

1000

3

 

 

2

20

200

2000

4

 

 

3

30

300

3000

5

 

 

4

40

400

4000

6

 

 

5

50

500

5000

В ячейке B3 записали формулу =C$5 + $D4. После этого ячейку B3 скопировали в ячейку C1. Какое число будет показано в ячейке C1?

Примечание: знак $ используется для обозначения абсолютной адресации.

1) 34                     2) 50                      3) 120                   4) 302

56)   Дан фрагмент электронной таблицы. Из ячейки D2 в одну из ячеек диапазона E1:E4 была скопирована формула. При копировании адреса ячеек в формуле автоматически изменились, и значение формулы стало равным 13. В какую ячейку была скопирована формула? В ответе укажите только одно число – номер строки, в которой расположена ячейка.

 

А

В

С

D

Е

1

10

9

8

7

 

2

9

8

7

=А$4+$B2

 

3

8

7

6

5

 

4

7

6

5

4

 

3

57)   Дан фрагмент электронной таблицы. Из ячейки D2 в одну из ячеек диапазона E1:E4 была скопирована формула. При копировании адреса ячеек в формуле автоматически изменились, и значение формулы стало равным 24. В какую ячейку была скопирована формула? В ответе укажите только одно число – номер строки, в которой расположена ячейка.

 

А

В

С

D

Е

1

10

9

8

7

 

2

9

8

7

=C$2+$A3

 

3

8

7

6

5

 

4

7

6

5

4

 

1

58)   Дан фрагмент электронной таблицы. Из ячейки D4 в одну из ячеек диапазона E1:E4 была скопирована формула. При копировании адреса ячеек в формуле автоматически изменились, и значение формулы стало равным 23. В какую ячейку была скопирована формула? В ответе укажите только одно число – номер строки, в которой расположена ячейка.

 

А

В

С

D

Е

1

10

9

8

7

 

2

9

8

7

6

 

3

8

7

6

5

 

4

7

6

5

=C$4+$A3

 

2

59)   Дан фрагмент электронной таблицы. Из ячейки B2 в одну из ячеек диапазона A1:A4 была скопирована формула. При копировании адреса ячеек в формуле автоматически изменились, и числовое значение в этой ячейке стало равным 4. В какую ячейку была скопирована формула? В ответе укажите только одно число – номер строки, в которой расположена ячейка.

 

А

В

С

D

Е

1

 

2

3

4

5

2

 

= D$3 + $C2

2

3

4

3

 

2

1

1

2

4

 

7

6

5

4

1

60)   Дан фрагмент электронной таблицы. Из ячейки B2 в одну из ячеек диапазона A1:A4 была скопирована формула. При копировании адреса ячеек в формуле автоматически изменились, и числовое значение в этой ячейке стало равным 19. В какую ячейку была скопирована формула? В ответе укажите только одно число – номер строки, в которой расположена ячейка.

 

А

В

С

D

Е

1

 

8

7

6

5

2

 

= D$3 + $C2

8

7

6

3

 

10

9

8

7

4

 

11

10

9

8

4

61)   Дан фрагмент электронной таблицы. Из ячейки D2 в ячейку E1 была скопирована формула. При копировании адреса ячеек в формуле автоматически изменились. Каким стало числовое значение ячейки Е1:

 

А

В

С

D

Е

1

1

10

100

1000

 

2

2

20

200

=$B2+C$3

20000

3

3

30

300

3000

30000

4

4

40

400

4000

40000

3010

62)   Дан фрагмент электронной таблицы. Из одной из ячеек диапазона B1:B4 в одну из ячеек диапазона A1:A4 была скопирована формула. При этом адреса в формуле автоматически изменились и числовое значение в ячейке, куда производилось копирование, стало равным 31. В какую ячейку была скопирована формула? В ответе укажите только одно число – номер строки, в которой расположена ячейка.

 

А

В

С

D

Е

1

 

=D$1+$D1

1

10

100

2

 

=D$2+$D2

50

20

200

3

 

=D$3+$D3

150

30

300

4

 

=D$4+$D4

200

40

400

3

63)   Дан фрагмент электронной таблицы. Из одной из ячеек диапазона B1:B4 в одну из ячеек диапазона A1:A4 была скопирована формула. При этом адреса в формуле автоматически изменились и числовое значение в ячейке, куда производилось копирование, стало равным 42. В какую ячейку была скопирована формула? В ответе укажите только одно число – номер строки, в которой расположена ячейка.

 

А

В

С

D

Е

1

 

=D$1+$D1

2

20

100

2

 

=D$2+$D2

52

40

200

3

 

=D$3+$D3

152

60

300

4

 

=D$4+$D4

252

80

400

2

64)   Дан фрагмент электронной таблицы. Из одной из ячеек диапазона B1:B4 в одну из ячеек диапазона A1:A4 была скопирована формула. При этом адреса в формуле автоматически изменились и числовое значение в ячейке, куда производилось копирование, стало равным 230. В какую ячейку была скопирована формула? В ответе укажите только одно число – номер строки, в которой расположена ячейка.

 

А

В

С

D

Е

1

 

=D$1+$D1

1

10

100

2

 

=D$2+$D2

50

20

200

3

 

=D$3+$D3

150

30

300

4

 

=D$4+$D4

200

40

400

3

65)   Дан фрагмент электронной таблицы. Из одной из ячеек диапазона B1:B4 в одну из ячеек диапазона A1:A4 была скопирована формула. При этом адреса в формуле автоматически изменились и числовое значение в ячейке, куда производилось копирование, стало равным 215. В какую ячейку была скопирована формула? В ответе укажите только одно число – номер строки, в которой расположена ячейка.

 

А

В

С

D

Е

1

 

=D$1+$D1

1

35

100

2

 

=D$2+$D2

50

45

200

3

 

=D$3+$D3

150

55

300

4

 

=D$4+$D4

200

65

400

4

66)   Дан фрагмент электронной таблицы. Из ячейки E4 в ячейку D3 была скопирована формула. При копировании адреса ячеек в формуле автоматически изменились. Каким стало числовое значение ячейки D3:

 

 

А

В

С

D

Е

1

40

4

400

70

7

2

30

3

300

60

6

3

20

2

200

 

5

4

10

1

100

40

= $B2 * C$3

8



[1] Источники заданий:

1.   Демонстрационные варианты ЕГЭ 2004-2016 гг.

2.   Тренировочные и диагностические работы МИОО.

3.   Гусева И.Ю. ЕГЭ. Информатика: раздаточный материал тренировочных тестов. — СПб: Тригон, 2009.

4.   Крылов С.С., Ушаков Д.М. ЕГЭ 2010. Информатика. Тематическая рабочая тетрадь. — М.: Экзамен, 2010.

5.   Якушкин П.А., Ушаков Д.М. Самое полное издание типовых вариантов реальных заданий ЕГЭ 2010. Информатика. — М.: Астрель, 2009.

6.   М.Э. Абрамян, С.С. Михалкович, Я.М. Русанова, М.И. Чердынцева. Информатика. ЕГЭ шаг за шагом. – М.: НИИ школьных технологий, 2010.

7.   Чуркина Т.Е. ЕГЭ 2011. Информатика. Тематические тренировочные задания. — М.: Эксмо, 2010.

8.   Якушкин П.А., Лещинер В.Р., Кириенко Д.П. ЕГЭ 2011. Информатика. Типовые тестовые задания. — М.: Экзамен, 2011.

9.   Самылкина Н.Н., Островская Е.М. ЕГЭ 2011. Информатика. Тематические тренировочные задания. — М.: Эксмо, 2010.